Re: DCDI - Kennlinienzündung für Vape- & Simson-Zündungen | Jetzt: FREI PROGRAMMIERBAR

  • Ich habe mir die ersten 9 Seiten durchgelesen und erstmal die Historie erarbeitet. Wenn ich das jetzt richtig nachvollziehe dann:

    1. DCDI-S für E-Zündung (09/2019)
    - mit blauem Poti

    2. DCDI-V für Vape (04/2020 bzw 07/2020)
    - blaues Poti entfällt
    - rote und grüne LED

    3. DCDI-V3 (12/2020)
    - 5 mm höher ("dicker")

    4. DCDI+ (12/2020)

    Im Update von Dezember 2020 wird der Vergleich zur V2 beschrieben, allerdings wurde die nie vorher erwähnt. Ich gehe aktuell davon aus, das mit der V2 die DCDI-V ab April 2020 gemeint ist.

    Dann würde ich aktuell vermuten, dass die DCDI-V3 und die DCDI+ die gleiche Hardware haben und die DCDI+ um ein Displaymodul ergänzt wurde. Das passt zum modularen Aufbau mit 2 Leiterplatten.

    Frage: Funktioniert die DCDI-V3 problemlos und die bekannten Problemchen treten nur bei der DCDI+ auf? Das würde schonmal Indizien geben, ob wir Software- oder Hardwareprobleme haben. Und wie sah es mit den Versionen davor aus?

    Die 5 mm mehr Aufbauhöhe ab DCDI-V3 könnten von der USB-Buchse vom Nano kommen, die steht am höchsten über. Die ISP-Schnittstelle (der 4-Buchsenstecker neben der roten und grünen LED) scheint ab -V3 entfallen zu sein. Ich kann es auf den Bildern nicht genau erkennen. D.h. vor der -V3 könnte ein anders Microcontrollerboard verbaut gewesen sein.

  • Das Verfahren ist ziemlich einfach und damit habe ich schon einige CDIs zerlegt: Heißluftpistole, Messer, kleiner Schraubendreher. Und viel Zeit.

    Am Gehäuse zuerst die Kanten entfernen. Entweder eine Raspel nehmen. Flex geht sicher auch. Bei der CDI hier hab ich die Kanten mit dem Akku-Hobel entfernt. Dann die CDI grunderwärmen und anschließend die Außenflächen ca. 2 cm schneiden, nachwärmen ( ca 5 Sekunden), schneiden, erwärmen usw. Sobald das PU zu kalt wird merkt man das relativ schnell und dann hilft nur Wärme.

    Das sieht dann so aus:

    Und dann ist es extreme Fleißarbeit. Stückchenweise ca. 5 Sek das PU erwärmen und schneiden. Erst grob, dann immer feiner. Aufpassen sobald man die ersten Komponenten sieht. Das PU nicht schmelzen oder verbrennen! Nur so weit erwärmen, dass es weich wird. Und die Feinarbeiten dann mit dem Schraubendreher. Von der Leiterplatte und den Bauelementen löst sich das ganz gut ab. Mit dem Messer bekommt man ca. 90-95 % vom PU weg und die letzten Prozent an den filigranen Stellen dann mit dem Schraubendreher. Richtig knifflig wird es vor allem bei kleinen SMD-Bauteilen, da ist ruckzuck die Beschriftung weggekratzt.

    Und das allerwichtigste: Ein gescheiter Handschuh für die linke Hand (als Rechtshänder). Spätestens nach 5 Minuten wird man wissen warum ;)

  • Heute war der Rest dran. Alles zerlegt, nun muss "nur" noch die Schaltung analysiert werden.
    Unter dem Buck-Boost-Converter (DC-DC-Spannungswandler) war der Rest für die Triggerschaltung verborgen.
    Insgesamt sieht alles solide aus. Die Leiterplatten sind sauber konstruiert, das ist kein Erstlingswerk. Alles was SMD-gelötet ist sieht auch sauber aus.

    Nur die THT-Bauteile sind schon recht bescheiden eingelötet. Das passt irgendwie nicht ins Gesamtbild. Das sagt natürlich erstmal nichts über die Funktionalität aus, aber es ist schon wunderlich. Die Signalaufbereitung ist der Knackpunkt an der Vape durch die innenliegenden Pickup-Spule und an der Stelle sieht die Ausführung auf der Leiterplatte am dürftigsten aus.

    Dann habe ich mir nochmal das OSZI-Bild aus dem Thread angeschaut und die Flankenqualität ist nicht besonders gut.
    Die grünen Pfeile sind das Signal der Pickupspulen. Die roten Pfeile das Komparatorsignals (das Bauteil, das aus den "Wellen" der Pickupspulen das Rechtecksignal für den Nano formt). Normalerweise müssten die Pfeilspitzen immer an der gleichen Stelle sein, aber die roten Pfeilspitzen sind immer an einer anderen Stelle. Das macht schon mehrere Grad Unterschied aus innerhalb einer Umdrehung, das darf auf keinen Fall sein.

    Das wäre in Summe eine erste Tendenz für EMV-Problemchen oder Designfehler. Nicht gut.

  • Ich oute mich mal und frage nach weil ich es nicht genau erkennen kann. Du meinst den delay vom Komparator zb im ersten Zyklus, da ist es am deutlichsten, oder? Die Größe der Pfeile spielt keine Rolle? Leider kann man nicht rein zoomen. Mehrfachflanken oder gezappel auf dem Analogsignal wären doof.

  • Das hat mir jetzt keine Ruhe gelassen und ich habe einen Blick ins Datenblatt vom Komparator geworfen.

    Auch wenn es Gründe gibt, davon abzuweichen, aber die Layout-Empfehlungen umzusetzen ist in der Regel nie verkehrt. Für die Versorgungsspannung für den Komparator wird hier ein Bypasskondensator von 0,1 uF empfohlen. Den gibt es auch, aber der ist ziemlich weit weg vom VCC (Versorgungsspannung). Da VCC vom Nano kommt und die Leiterbahn schon recht lang ist. Weiterhin ist die Leiterbahn von OUT zum NANO sehr lang. Zwar läuft der Ausgang vom Komparator nicht parallel zu den Eingängen, dafür sitzt aber die DC-DC-Spannungsquelle direkt über dem Komparator! Und da das ein Schaltregler mit irgendwas >100 kHz Schaltfrequenz ist, besteht hier direkte Gefahr für transiente Einkopplungen. Das könnte auch durchaus den unsauberen Signalverlauf vom Komparator erklären.
    Die Schaltregler sind teilweise kleine EMV-Dreckschweine.

    Es hätte sicher nicht geschadet, den Komparator so nah wie möglich an den Nano zu setzen und so weit weg wie möglich vom Buck-Boost Converter.
    Das lässt sich leider nachträglich nicht mehr korrigieren oder kompensieren, das bedeutet zwangsweise ein Redesign von Board, wenn was zutreffen sollte.

    Damit das Moped rückwärts fährt, muss ja viel Vorzündung vorhanden sein. Entweider die Kurve hat in den unteren Drehzahlen viel Vorzündung (was aber bei einer frei programmierbaren Kurve keinen Sinn macht), oder irgendwas in der Signalverarbeitung sorgt dafür, dass die Zündkurve unerwünschterweise manipuliert wird.

  • Ich oute mich mal und frage nach weil ich es nicht genau erkennen kann. Du meinst den delay vom Komparator zb im ersten Zyklus, da ist es am deutlichsten, oder? Die Größe der Pfeile spielt keine Rolle? Leider kann man nicht rein zoomen. Mehrfachflanken oder gezappel auf dem Analogsignal wären doof.

    Ja genau. Auf Seite 3 ist das Originalbild, da sieht man es besser.

    Die größe der Pfeile ist irrelevant, ist nur mit Paint gekrakelt.

  • Ich vermute es ist eine ungünstige Kombination aus Drehungleichförmigkeit vom 1 Zyl und Rauschen auf dem Analogsignal der Vape. Quick and dirty habe ich sowas einfach mal mit nem Drahtwiderstand von einigen 0.1k insgesamt runter skaliert und hatte dann einen reproduzierbaren Funken. War aber andere Hardware und etwas Glück

  • Der Kollege hier berichtet auch von "Crashes" vom Arduino Nano im Automotive-Bereich:

    External Content youtu.be
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    Abhilfe hat hier eine Vulkanfiberdichtung ("fish paper") und Kupferdrahtfolie ( "copper screen") gebracht, dass er über dem Prozessor und Oszillator angebracht hat. Das Kupfer hat er an den Schild der USB-Buchse gelötet.

    Das wäre durchaus nachrüstbar. Die Position vom Nano ist ja nun bekannt. Da könnte man mit einem Schaftfräser bis zur USB-Buchse fräsen, der Schild verträgt paar Kratzer vom Fräser. Von da an bis ca. 1 mm über dem Prozesser freifräsen. Die Pins auf dem Board können dabei als "Tiefenmaß" gelten. Wenn die erreicht sind, das Kupferdrahtgitter platzieren und an den Schild löten. Das restliche PU auf dem Prozessor ist dann die Isolation, dann braucht es kein Vulkanfiber o.ä.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!